Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 01 Apr 2011, 18:02
NeXuM NeXuM is offline
 
Join Date: Mar 2003
PHP 5.3 and vBulletin 3.6.4

My webhost just upgrader PHP to version 5.3 and now i am getting errors on three vbulletin forums (version 3.6.4)

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 45

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 93

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 97

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 105

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 116

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 120

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 128

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 197

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/init.php on line 404

Deprecated: Assigning the return value of new by reference is deprecated in /var/alternc/html/a/anarchoi/includes/class_core.php on line 2345

Deprecated: Function set_magic_quotes_runtime() is deprecated in class_core.php on line 1514

is there a way to fix those errors ? i really cant upgrade to a newer version of vbulletin, i have spent hundreds of hours customizing my forums.... half of my forum is based on mods that doesnt exist in newer versions, and if i upgrade i will loose my custom scripts, custom mods, custom template, etc....

If it is impossible to fix the errors without upgrading, could someone please tell me how the errors can affect my forum ?? If i just turn off error display, will it affect my forum somehow ? are the deprecated functions very important for the basic functionement of the forum?
Reply With Quote
  #2  
Old 01 Apr 2011, 18:22
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
vB3.6 (and 3.7 and most of 3.8) will not work with PHP 5.3.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 01 Apr 2011, 18:38
NeXuM NeXuM is offline
 
Join Date: Mar 2003
one of my forums under 3.6.4 is still working but displaying a couple of errors...

if i turn off the error displaying, can i know how these errors will affect my forums ?

thanks
Reply With Quote
  #4  
Old 01 Apr 2011, 19:10
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I do not know what they will do. Running 3.6.4 is not supported under PHP 5.3. It's not been tested at all.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #5  
Old 17 Jun 2011, 16:48
FudgeBalls2002 FudgeBalls2002 is offline
 
Join Date: Feb 2006
Real name: Matt
Just happened to me this morning...I have a heavily modded forum and didn't really want to pay money to upgrade there's really no option for this problem?
Reply With Quote
  #6  
Old 17 Jun 2011, 16:54
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
The errors are mostly just warnings of deprecated functionality, so the forum should work, except you will need to disable the error messages somehow. However, the functionality is likely to be removed from php at some point, then you will have problems.
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #7  
Old 17 Jun 2011, 17:15
Frosty Frosty is offline
 
Join Date: Apr 2011
Just decrease the version, I did the same. It should work without any problems or whatsoever on PHP 5.1.6.
Reply With Quote
  #8  
Old 17 Jun 2011, 17:40
Adrian Schneider's Avatar
Adrian Schneider Adrian Schneider is offline
 
Join Date: Jul 2004
You could probably do a mass find replace...

"=&" with "="

This should take care of the majority of them, but I'd definitely back up first or try it locally first.
Reply With Quote
  #9  
Old 17 Jun 2011, 18:00
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
Try
ini_set(display_errors, 0);

In your config.php file.
__________________
Looking for ImpEx?
Reply With Quote
  #10  
Old 04 Feb 2012, 12:29
Eslob Eslob is offline
 
Join Date: May 2010
Originally Posted by Adrian Schneider View Post
You could probably do a mass find replace...

"=&" with "="

This should take care of the majority of them, but I'd definitely back up first or try it locally first.
This fixes the problem.

As i have dedicated server and my forum on it.

I got this error and now i'm downgrading my php version to 5.2.X.

And keep the php as it is without upgrades, unless if i plan to go for 4.X.
__________________
Eslob Forums, base of information & discussion..
منتديات | عالم حواء | يوتيوب | خواطر | سبق | صور سيارات
Reply With Quote
  #11  
Old 11 May 2012, 12:35
IRANCITY's Avatar
IRANCITY IRANCITY is offline
 
Join Date: Nov 2007
please Fix VB 3.8 for PHP 5.3 !
Reply With Quote
  #12  
Old 11 May 2012, 12:40
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
vB 3.8.7 works perfectly fine with php 5.3
__________________
Former vBulletin.org Staff Member


Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #13  
Old 11 May 2012, 14:57
Xp.Warrior Xp.Warrior is offline
 
Join Date: Mar 2012
Brother You Have 2 Ways To fix Thease Errors
1 You Request To Your Hosting Server To Downgrade php5.3x To php5.2 Beacues php5.3x Not Supported vbulletin old versions php5.3 Only Support vbulletin 3.8.5 or Up Version
2 Way You Upgrade Your This Version Of Vbulletin To Vbulletin 3.8.5 and Up
I Hope This Is Help Full For You
Reply With Quote
  #14  
Old 19 Apr 2013, 18:36
mrspring mrspring is offline
 
Join Date: Apr 2008
Originally Posted by Lynne View Post
vB3.6 (and 3.7 and most of 3.8) will not work with PHP 5.3.
Can You be a little clearer on this? And how long will non version 4 customers be able to sustain their boards, if they are regularly upgrading PHP?
Reply With Quote
  #15  
Old 20 Apr 2013, 00:33
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Of the 3.x series, only 3.8.5 and newer will work with PHP5.3 and only version 3.8.8 will work with PHP5.4
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 09:07.

Layout Options | Width: Wide Color: