Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
MGC Chatbox (with AJAX) Details »
MGC Chatbox (with AJAX)
Mod Version: 1.5, by VBDev (Coder) VBDev is offline
Developer Last Online: Feb 2021 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.9 Rating: (82 votes - 4.71 average) Installs: 763
Released: 30 May 2007 Last Update: 20 Sep 2007 Downloads: 11536
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

Last version - MGC Chatbox Evo available : here

Description

When I had left the vBulletin world, I was in the past the co-author of a little chatbox (shoutbox), very well known in the vBulletin world.
This chatbox had been developed by Svaliotti (known as Poseidon on vb.org) for vB2 in the past and I had made the porterage (with is authorisation as we were both members of the same french non-official support forum) and the improvement for vB3.

It is thus normal that in my return in the vBulletin world, I begin by getting down to this hack. Even if several versions of chatbox are already present in the vBulletin world, I said to myself that it would be a good thing to make a made in France.

Naturally, I don't deal with a "copy" version of the other chatbox, I have any coded at the beginning (it was preferable because the front code wasn't so clean any more), and I integrated a good quantity of very interesting features.

New version features

The new version contains all the features from the previous version. Description of these versions can be found in Sofia's post hereabove (http://www.vbulletin.org/forum/showpost.php?p=1257510&postcount=3).

Modifications from previous version are the following :
  • 1.5 :
    • Fixed bugs :
      • Chatbox is shown two times in full page mode when the Display on all pages under the navbar option is selected.
      • "Fermer" is not in a sentence.
      • Overflow problem with Netscape.
      • Uppercase transformed to lowercase in the PM channel.
      • The ban cron debans user indefinitly banned.
      • Chatbox continuously loading on some forums.
      • Inactivity and guests problem.
      • Team icon blinking is not working properly.
      • Coma error in the who is online.
      • 2 spaces instead of one between the date and the time.
    • New functionnalities :
      • Option to deactivate the random smilies.
      • Option to deactivate the automatic PM sending when banning a user.
      • New permission to allow or not the downloading of shouts.
      • Option to specify the name under which unregistered users shouts appear.
      • Syntax change for the /ban, /ignore, /del, /pm commands : Possibility to use them with the username or the userid (For more information about the new syntax, check the help button in the chatbox).
    • Removed functionnalities :
This hack is very light in term of queries : only one for every recharging / refreshment of the chatbox and 5 for the statistics in the load of the page if you actiate them. If you don't activate advanced options of course as stated aside each in the acp

Installation

Read the file "Installation" in the pack.

Once the installation is ended, go in usergroups and edit permissions to see the Chatbox.

By default, no group has access to the chatbox.

Screenshots

The screenshots are in french as I have made it on an online website which is in french. Don't hesitate to give me new one if you want in english

They are up to date of 1.3 version.

See the following post : http://www.vbulletin.org/forum/showpost.php?p=1292136&postcount=559

User manual

Coming soon ...

Copyright

This hack is under copyright MGC (Mtor&Grog Corporation) 2007-forever and was developed for vBulletin-Resources.com & vb-hacks.org. Its redistribution on another forum that vbulletin-ressources.com, vb-hacks.org or vbulletin.org are prohibited without aggreement of the authors!

Evolutions and improvements

This sixth version of the chatbox is already very complete, but like each product, its evolution depends on all. Then don't hesitate especially to share your ideas of improvements so that we can improve even more this chatbox.

Languages

Actually available :
  1. French
  2. English
  3. Arabic [Translator : alessai]
  4. German [Translator : captainslater]
  5. Vietnamese [Translator : Anhyeu12000]
  6. Turkish [Translator : neutralizer and bocek]
  7. Spanish [Translator : obmob] [TO BE UPDATED FOR 1.5]
To be available [Translation in progress] :
  1. Bosnian [Translator : Benjaminbih]
[FONT='Calibri','sans-serif']For the translators : phrases with version number 1.5 in the English language file are the one that have been modified or added in the new version so you should probably find the modification for your language file easily.[/font]

Contact me if you want to participate and add your own country language file

Support

Several possible problems are explained in the file "Read Me"
Chatbox in iBProarcade and vBadvanced CMPS

See the readme file for iBProarcade.

For vbadvanced, a module is available here : http://www.vbulletin.org/forum/showthread.php?t=163628.

FAQ

Q: I installed the chatbox but it doesn't display
R: Check if you have allowed users (permissions in usergroups)

Q: I see shouts but in the collapsed chatbox
R: You can specify number of shouts in the collapsed chatbox. If you don't want to see it, put "0" for this option.

Q: The chatbox doesn't display below or in the top of one of the pages while in the other position it displays
R: You use a style and it's possible that variables used in templates aren't present. (Read the file "Read Me")

Q: I have a problem with accents in the Chatbox
R: Read the file "Read Me"

Q: How to change the value of color for date and for command /me?
R: When you add additionnal CSS for each style, you can change color in class CSS.

Thanks to Sofia for her earlier help on the chatbox.

You can donate if you want to show your support

Last version - MGC Chatbox Evo available : here

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Chat Modifications MGC Chatbox with AJAX VBDev Modification Graveyard 4 19 Dec 2007 06:25

  #661  
Old 16 Jul 2007, 21:33
silvermerc silvermerc is offline
 
Join Date: Apr 2006
Real name: Ross
im currently using IE (with the tabbed browsing cant remember what version it is but i think its most recent)
Reply With Quote
  #662  
Old 16 Jul 2007, 21:40
Sofia Sofia is offline
 
Join Date: Oct 2006
Real name: Sofia
it's even more beautiful now! Great work for this release, as usual
Reply With Quote
  #663  
Old 16 Jul 2007, 21:52
Pottsy Pottsy is offline
 
Join Date: Sep 2006
Originally Posted by maidos View Post
it seems also that some members is having issue only seeing idle using firefox

http://img360.imageshack.us/img360/7432/untitledul3.jpg

tried refreshing but doesnt work
This is exactly what we got on upgrade. The files and product were installed correctly, but it just needed a CTRL + F5. I put a note on the forum about this, and a few replied that they needed the refresh to get it to work.
Reply With Quote
  #664  
Old 16 Jul 2007, 22:29
Anhyeu12000 Anhyeu12000 is offline
 
Join Date: Jul 2007
How to change MGC Chatbox's background color, I want my MGC Chatbox's background is white?
Thanks !
Reply With Quote
  #665  
Old 16 Jul 2007, 22:51
VBDev's Avatar
VBDev VBDev is offline
 
Join Date: Jan 2004
Real name: Clément
Originally Posted by maidos View Post
yeah u r correct as usual... thanks

also how about the name and msg space? :P any help
I will look that for next version look at the bug list and todo list.

Originally Posted by Pottsy View Post
This is exactly what we got on upgrade. The files and product were installed correctly, but it just needed a CTRL + F5. I put a note on the forum about this, and a few replied that they needed the refresh to get it to work.
After their first refresh everything then worked fine ?

Originally Posted by J1755EC6A244 View Post
How to change MGC Chatbox's background color, I want my MGC Chatbox's background is white?
Thanks !
You have to do template modifications (mgc_chatbox template), this is html edit
Reply With Quote
  #666  
Old 16 Jul 2007, 23:01
Kyderoy Kyderoy is offline
 
Join Date: Feb 2005
Don't know what's wrong, I can see the chatbox but none of my members can see it. I just upgraded from 1.2 to 1.3
Reply With Quote
  #667  
Old 16 Jul 2007, 23:37
alessai alessai is offline
 
Join Date: Mar 2006
Have you set the permissions for unregistered users ??
]

ive put yes for "Can see MGC Chatbox?" (for unregistered) and the others no is that right?
Reply With Quote
  #668  
Old 17 Jul 2007, 01:42
Rukas Rukas is offline
 
Join Date: Aug 2004
Is it possible to get this to show up in just one particular forum?
Reply With Quote
  #669  
Old 17 Jul 2007, 02:48
Sykko's Avatar
Sykko Sykko is offline
 
Join Date: Jun 2007
Originally Posted by VBDev View Post
Yes removing the bitfield file of the chatbox and then rebuilding bitfields will solve that.

Sorry that my product didn't fits your needs
dont worry about it... the truth is I think I was biting off more than I could chew with it, was a bit more than I knew how to do.

your box had better features but the other one seems to work ok too and the members are ok...

eventually we may try again after we get better at doing installs like this one it would be a nice little upgrade
__________________
§èè¥ä§;
Sykko
(of tehnoobs.com A board that prooves freedom on a forum is a good thing)
Reply With Quote
  #670  
Old 17 Jul 2007, 02:51
Rukas Rukas is offline
 
Join Date: Aug 2004
Is it possible to have the box show up on one forum only, or alternately have it work with one style only so I can then assign one forum with that template.

Ive tried the whole # $search_text = '$forumhome_markread_script';
replace with $search_text = '$chatbox_forumhome'; but it still displays on all styles.
Reply With Quote
  #671  
Old 17 Jul 2007, 04:17
NeutralizeR NeutralizeR is offline
 
Join Date: Aug 2005
I upgraded to the 1.3 version, edited my chatbox templates, changed the settings, tested it for a while... and suddenly it stopped working. It says "Loading..." but nothing happens and when i enter a message it redirects me to the archives. The buttons are also inactive and IE gives me a javascript error message:

"Error: 'auto_refresh'" undefined.

I fully uninstalled the product, reverted the templates (a few times) and made a fresh insallation but still no luck. I'm stuck here.

I even dropped all of the chatbox tables via phpmyadmin, installed the earlier versions, cleaned my browser caches (both in IE and FF). Help needed
__________________
MsXLabs Forum
Reply With Quote
  #672  
Old 17 Jul 2007, 05:41
VBDev's Avatar
VBDev VBDev is offline
 
Join Date: Jan 2004
Real name: Clément
Originally Posted by alessai View Post
]

ive put yes for "Can see MGC Chatbox?" (for unregistered) and the others no is that right?
Yes yes that's right, but with those options the unregistered still can't see ?

Humm I thought I had tested it, I'll put in the possible bugs list so that I can test it and correct in case I made a mistake.

Originally Posted by Sykko View Post
dont worry about it... the truth is I think I was biting off more than I could chew with it, was a bit more than I knew how to do.

your box had better features but the other one seems to work ok too and the members are ok...

eventually we may try again after we get better at doing installs like this one it would be a nice little upgrade
Ok

Originally Posted by Rukas View Post
Is it possible to have the box show up on one forum only, or alternately have it work with one style only so I can then assign one forum with that template.

Ive tried the whole # $search_text = '$forumhome_markread_script';
replace with $search_text = '$chatbox_forumhome'; but it still displays on all styles.
If you do so and put $chatbox_forumhome on one style, it shall not be seen on other styles (only for forumhome as you seem to do the modification for the forumhome template only).

Originally Posted by NeutralizeR View Post
I upgraded to the 1.3 version, edited my chatbox templates, changed the settings, tested it for a while... and suddenly it stopped working. It says "Loading..." but nothing happens and when i enter a message it redirects me to the archives. The buttons are also inactive and IE gives me a javascript error message:

"Error: 'auto_refresh'" undefined.

I fully uninstalled the product, reverted the templates (a few times) and made a fresh insallation but still no luck. I'm stuck here.

I even dropped all of the chatbox tables via phpmyadmin, installed the earlier versions, cleaned my browser caches (both in IE and FF). Help needed
Did you revert templates ?
Did you uploaded the js files correctly in the clientscript directory ?

This is possible errors when the javascript is firing such errors.
Reply With Quote
  #673  
Old 17 Jul 2007, 06:52
NeutralizeR NeutralizeR is offline
 
Join Date: Aug 2005
Did you revert templates ?
Did you uploaded the js files correctly in the clientscript directory ?

This is possible errors when the javascript is firing such errors.
5 times at least... I just renamed the file as mgc_chatbox2.js and replaced the line in the template but it didn't change anything... I restarted apache and mysql... (memcache+memcached+xcache installed) It's simply useless... Advice?
__________________
MsXLabs Forum
Reply With Quote
  #674  
Old 17 Jul 2007, 07:01
VBDev's Avatar
VBDev VBDev is offline
 
Join Date: Jan 2004
Real name: Clément
:S This seems to be a really strange strange problem especially with the fact that you told me it worked before and stopped working.

Does IE tells you any error ? Have you tried on a different server ?
Reply With Quote
  #675  
Old 17 Jul 2007, 07:11
NeutralizeR NeutralizeR is offline
 
Join Date: Aug 2005
Originally Posted by VBDev View Post
:S This seems to be a really strange strange problem especially with the fact that you told me it worked before and stopped working.

Does IE tells you any error ? Have you tried on a different server ?
I've 4 servers running that web site. 3 web servers and 1 db server. All of the servers have this issue. Can you check it for me if i PM the needed info?
__________________
MsXLabs Forum
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 18:46.

Layout Options | Width: Wide Color: